We have a new documentation site for cPanel & WHM! You can find our new documentation site at docs.cpanel.net.

We will continue to maintain our API documentation on this server.

Child pages
  • WHM API 1 Functions - php_get_vhosts_by_version
Skip to end of metadata
Go to start of metadata

Description

This function lists the virtual hosts that use a specified version of PHP.


Note:

This document only applies to systems that run EasyApache 4.

Important:

In cPanel & WHM version 76 and later, when you disable the Web Server role, the system disables this function.

Examples 


 JSON API
https://hostname.example.com:2087/cpsess##########/json-api/php_get_vhosts_by_version?api.version=1&version=ea-php56
 XML API
https://hostname.example.com:2087/cpsess##########/xml-api/php_get_vhosts_by_version?api.version=1&version=ea-php56
 Command Line
whmapi1 php_get_vhosts_by_version version=ea-php56


Notes:

  • Unless otherwise noted, you must URI-encode values.
  • For more information and additional output options, read our Guide to WHM API 1 documentation or run the whmapi1 --help command.
  • If you run CloudLinux™, you must use the full path of the whmapi1 command:

    /usr/local/cpanel/bin/whmapi1

 Output (JSON)
{
   "metadata":{
      "reason":"OK",
      "version":1,
      "result":1,
      "command":"php_get_vhosts_by_version"
   },
   "data":{
      "vhosts":[
         "example.com",
         "new.example.com",
         "example1.com",
         "example2.com"
      ]
   }
}
 Output (XML)
<result>
    <metadata>
        <result>1</result>
        <version>1</version>
        <reason>OK</reason>
        <command>php_get_vhosts_by_version</command>
    </metadata>
    <data>
        <vhosts>new.example.com</vhosts>
        <vhosts>example.com</vhosts>
        <vhosts>example1.com</vhosts>
        <vhosts>example2.com</vhosts>
    </data>
</result>


Note:

Use WHM's API Shell interface (WHM >> Home >> Development >> API Shell) to directly test WHM API calls.

Parameters  

Parameter
Type
Description
Possible values
Example
versionstring

Required

The name of an installed PHP package.


Important:

We deprecated PHP 5.6 and PHP 7.0 in cPanel & WHM version 84. We will remove them in a future version. For more information, read our cPanel Deprecation Plan documentation.

  • ea-php54
  • ea-php55
  • ea-php56
  • ea-php70
  • ea-php71
  • ea-php72
  • inherit
  • Any custom PHP package name.
ea-php56

Returns

ReturnTypeDescriptionPossible valuesExample

vhosts

arrayAn array of the virtual hosts that use the specified PHP version.

Any valid virtual host name.

example.com