cPanel & WHM no longer develops or updates EasyApache 3. We deprecated EasyApache 3 on December 31, 2018. We removed support for EasyApache 3 in cPanel & WHM version 78.
EasyApache 3.22 Release Notes - EasyApache - cPanel Documentation
Page tree
Skip to end of metadata
Go to start of metadata

Last updated January 13, 2014

These Release Notes detail feature updates in EasyApache version 3.22

New Features

PHP 5.5

We have added PHP 5.5 to the list of PHP versions that are available in EasyApache. The latest version of PHP 5.5 is version 5.5.8.

PHP 5.5 is only available for cPanel & WHM version 11.38 and later.

PHP 5.5 is currently incompatible with the following:

  • Zend Guard
  • Source Guardian
  • eAccelerator
  • xCache
  • ionCube Loader

If you select PHP 5.5 in EasyApache, these modules will be automatically disabled.

The following options are disabled in PHP 5.5:

  • Path Info Check (--disable-path-info-check)
  • Curlwrappers (--withcurlwrappers)

Because of incompatibility with these modules and options, we have marked this release as EXPERIMENTAL. We recommend that you test your scripts and applications on PHP 5.5.6 before you upgrade your production servers.

The EasyApache team will update these modules as their developers make compatible versions available. As stated previously, a CentOS 5-compatible version is also in development. After all compatibility issues have been resolved, the EXPERIMENTAL tag will be removed.

It is our goal to remove the EXPERIMENTAL tag in early 2014.

For more information about PHP 5.5.8, read Migrating from PHP 5.4.x to PHP 5.5.x and PHP 5 ChangeLog at PHP’s website.

Modified or Updated Features

ionCube Loader 4.4.1

We have upgraded the version of ionCube Loader available through EasyApache to version 4.4.1. ionCube Loader is now compatible with PHP 5.4.

For more information about ionCube Loader, read the FAQ at ionCube’s site.

eAccelerator version 2012-08-16

We have upgraded the version of eAccelerator available through EasyApache to version 2012-08-16. eAccelerator is now compatible with PHP 5.4.

Note:

You should not install both EAccelerator and XCache. If you select XCache or EAccelerator, a warning message will appear.

For more information about eAccelerator, read the documentation at eAccelerator’s site.

Tomcat version 7.0.42-1

We have upgraded the version of Tomcat available through EasyApache to version 7.0.42-1.

For more information about changes in Tomcat 7.0.42-1, read the Tomcat Changelog at the Apache Software Foundation.

For more information about Tomcat as it is available through EasyApache, read our Tomcat documentation.

Note:

Tomcat 7.0.42-1 will appear as Tomcat 7.0.41 in the EasyApache interface. This is a temporary issue and will be resolved in the next EasyApache release.

Appendix A

ModSecurity version 2.7.5

We have upgraded the version of mod_security available through EasyApache to version 2.7.5.

For more information about the new ModSecurity features, read our ModSecurity documentation.

Appendix B

EAccelerator now compatible with PHP 5.4

We have upgraded EAccelerator to resolve multiple EAccelerator issues.

PHP 5.5 compatible with CentOS 5

We have upgraded the ICU libraries in PHP 5.5 so that PHP 5.5 through EasyApache is now compatible with CentOS 5.9.

Zend Guard version 6

We have upgraded Zend Guard Loader to version 6, which is now compatible with PHP 5.4.

Note:

The Apache information page will incorrectly show that Zend Guard Loader is version 3.3. However, if you compare the md5 checksum of the EasyApache package to the published md5 checksum, they are the same. This will be resolved when the vendor provides the correct version label in Zend Guard Loader.

For more information about Zend Guard, read the What's New documentation at Zend's site.

Appendix C

EAccelerator parent class error resolved

We have resolved an issue with a parent class error in EAccelerator.

However, you may still encounter error 500 or a page timeout with EAccelerator. We are aware of this issue, and we will release a resolution shortly.

Appendix D

Mod_Ruid2 version 0.9.8

We have upgraded the version of mod_ruid2 available through EasyApache to version 0.9.8.

Mod_Deflate

Mod_Deflate is now enabled by default for Apache versions 2.0 and newer.