cPanel & WHM no longer develops EasyApache 3 and only releases security updates for it. We will deprecate EasyApache 3 on December 31, 2018. After that date, we will no longer update EasyApache 3. In cPanel & WHM version 78, we will remove support for EasyApache 3. For more information, read our cPanel Long-Term Support documentation. If you do not upgrade to EasyApache 4, you cannot upgrade to cPanel & WHM version 78. We strongly recommend that you upgrade to EasyApache 4. For more information, read our EasyApache 4 documentation.
PHP Module: Pdo - EasyApache - cPanel Documentation
Page tree
Skip to end of metadata
Go to start of metadata

Overview

pdo – PDO (DB) Support

Profile

Namepdo
PHP Version5
Profile ValueCpanel::Easy::PHP5::PDO
Reverse BooleanNo

Compatibility

This module has no known compatibility issues.

Notes

If this module is disabled:

  • --disable-pdo will be added to PHP's configuration options
  • extension=pdo.so will be removed from /usr/local/lib/php.ini
  • extension=sqlite.so will be removed from /usr/local/lib/php.ini

If this module is enabled:

  • If Cpanel::Easy::PHP5::Versioning is enabled, PDO will be built as a static module.
  • Compiled as a shared module (default):
    • If you enable this option, --enable-pdo=shared will be added to PHP's configuration options.
    • If you enable this option, --enable-pdo-sqlite=shared (--enable-pdo-sqlite when it compiles statically) will be added to PHP's configuration options.
    • If PHP is older than version 5.4 and you enable this option, -enable-sqlite will be added to PHP's configuration options.
  • Compiled as a static module (Cpanel::Easy::PHP5::Versioning enabled): 
    • If you enable this option, --enable-pdo to PHP's will be added to PHP's configuration options.
    • If you enable this option, --enable-pdo-sqlite will be added to PHP's configuration options.
    • If PHP is older than version 5.4 and you enable this option, --enable-sqlite=shared will be added to PHP's configuration options.

Dependencies

Profile option Cpanel::Easy::PHP5::SQLite3 will be enabled. Note that SQLite3 is a reverse-boolean option, so it will be set to 0.

Vendor documentation

PHP versionDocumentation
5Docs