Child pages
  • WHM API 1 Functions - php_set_handler

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

Description

Excerpt

This function sets a PHP version's handler.

Multiexcerpt include
SpaceWithExcerptcom.atlassian.confluence.content.render.xhtml.model.resource.identifiers.SpaceResourceIdentifier@12665
MultiExcerptNameAPIDisabledWebServerRole
PageWithExcerptLIB:_ServerRoleDisabledAPI

Panel
bgColor#F2F2F2
borderStylenone

Examples 


Panel
bgColor#FFFFFF
borderStylenone


Expand
titleJSON API


Code Block
languagexml
https://hostname.example.com:2087/cpsess##########/json-api/php_set_handler?api.version=1&version=ea-php70&handler=suphp



Expand
titleXML API


Code Block
languagexml
https://hostname.example.com:2087/cpsess##########/xml-api/php_set_handler?api.version=1&version=ea-php70&handler=suphp



Expand
titleCommand Line


Code Block
languagebash
whmapi1 php_set_handler version=ea-php70 handler=suphp

Include Page
LIB:_WHMAPI1CLINote
LIB:_WHMAPI1CLINote


Expand
titleOutput (JSON)


Code Block
languagetext
linenumberstrue
{
   "data":{
   },
   "metadata":{
      "version":1,
      "reason":"OK",
      "result":"1",
      "command":"php_set_handler"
   }
}



Expand
titleOutput (XML)


Code Block
languagetext
linenumberstrue
<result>
    <data/>
    <metadata>
        <version>1</version>
        <reason>OK</reason>
        <result>1</result>
        <command>php_set_handler</command>
    </metadata>
</result>


Include Page
LIB:_WHMAPIShellNote
LIB:_WHMAPIShellNote


Parameters

ParameterTypeDescriptionPossible valuesExample

version

string

Required

An installed PHP version.

Include Page
LIB:_APIPHPVersions
LIB:_APIPHPVersions
ea-php70
handlerstring

Required

An installed PHP handler.

  • cgi
  • suphp
  • dso
  • none
suphp

Returns

This function returns only metadata.