Page tree
Skip to end of metadata
Go to start of metadata

You are viewing an old version of this page. View the current version.

Compare with Current View Page History

« Previous Version 3 Current »

Overview 

cPanel, L.L.C. releases new builds often, which may make it hard to keep your servers consistent. Disabling updates is a common way to work around this, or you can use our release tiers. However, our Long-Term Support (LTS) tier may be a better option for you in many cases.

Note:

In cPanel & WHM version 62 and higher, the /etc/cpanel/TIERS.json file contains LTS settings.

We use these guidelines for LTS releases: 

  • Only one release each year qualifies for LTS. Other versions will only receive updates in the STABLE, RELEASE, or CURRENT tiers.

  • As of cPanel & WHM version 62, the /etc/cpanel/TIERS.json file contains a JSON file structure which indicates LTS.
  • Any cPanel & WHM version that isn't the LTS version does not qualify for LTS.
  • The lifespan of each release extends through March 31st of the following year.

  • cPanel, L.L.C. may extend a version's LTS period at our discretion.

    Note:

    Development releases of cPanel & WHM do not qualify for LTS. We don't use their publication dates to calculate an LTS version's lifespan.

  • New and existing installations can upgrade to the LTS tier.
  • Over the lifespan of an LTS release, cPanel, L.L.C. will provide security and other critical updates.

    Note:

    We won't add new features to LTS releases unless they're critical or ensure compatibility with later versions.

Third-party applications

cPanel & WHM provides various third-party applications. For the life of an LTS release, we provide critical updates for third-party applications. However, we may provide them as back-ported patches instead of upgrades.

EasyApache

cPanel, L.L.C. releases EasyApache separately from cPanel & WHM's release schedule.

cPanel, L.L.C. provides EasyApache updates for an LTS release until the LTS release reaches End of Life (EOL). If the LTS version doesn't meet a new EasyApache feature or function's requirements, EasyApache will update. However, we can't guarantee or support that update. 

EasyApache 3 deprecation

cPanel & WHM no longer develops EasyApache 3 and only releases security updates for it. We deprecated EasyApache 3 on December 31, 2018. We no longer update EasyApache 3. In cPanel & WHM version 78, we will remove support for EasyApache 3. 

We strongly recommend that you upgrade to EasyApache 4. For more information, read our EasyApache 4 documentation. 

PHP

EasyApache uses the php.net supported versions timeline

RPMs for unsupported versions of PHP will remain on the cPanel, L.L.C. mirrors and servers. However, we will not provide any further updates.

Site Software (cPAddons)

cPAddons in cPanel's Site Software interface (Home >> Software >> Site Software) get updates throughout the LTS release's lifetime.

WHM Plugins

Plugins in WHM's Manage Plugins interface (Home >> cPanel >> Manage Plugins) get updates throughout the LTS release's lifetime.

Schedule for Long-Term Support releases of cPanel & WHM

For cPanel & WHM version 62 and later, LTS release lifespans extend to March 31st of the year after that version's release date. We will no longer provide LTS for versions that fall outside of this time frame. Only one release each year qualifies for LTS. Other versions will only get updates while they're in the STABLE, RELEASE, or CURRENT tiers. Any cPanel & WHM version that's not present in this table doesn't qualify for LTS.
cPanel & WHM VersionApproximate Release DateAnticipated End of Life
62February 2017June 2018
70May 2018March 2019
78February 2019March 2020

Important:

When cPanel & WHM releases reach End of Life:

  • They become unavailable for installation.
  • They don't receive fixes or patches from cPanel, L.L.C.
  • We archive their documentation.

Additional documentation

  • No labels