Page tree
Skip to end of metadata
Go to start of metadata

Unable to render {include} The included page could not be found.

Descripción general

Este documento provee ejemplos de fallas de instalación de RPM para ayudarle a identificar y resolver problemas que usted tal vez encuentre durante el proceso.

Excluido en el archivo yum

En este ejemplo, wget causa que el proceso de instalación falle:

[20130131.123334] Setting up Install Process
[20130131.123334] No package wget available.
[20130131.123335] Nothing to do
[20130131.123339] E Sysup: Needed system RPMs were not installed: wget
[20130131.123339] ***** FATAL: Cannot proceed. Needed system RPMs were not installed. 
[20130131.123339] The Administrator will be notified to review this output when this script completes
[20130131.123339] E Detected events which require user notification during updatenow. Will send iContact the log
=> Log closed Thu Jan 31 12:33:39 2013
[20130131.123339] E Running `/usr/local/cpanel/scripts/updatenow --upcp --log=/var/cpanel/updatelogs/update.1359657200.log` failed, exited with code 4608
=> Log closed Thu Jan 31 12:33:39 2013  

Es posible que un paquete requerido se haya excluido de las actualizaciones en su archivo yum.conf. Esto es común entre los usuarios del paquete de scripts Fantastico. Usted tendrá que eliminar el paquete de la lista de exclusión yum.conf y ejecutar el proceso de actualización nuevamente.

Conflicto con un repositorio de terceros

En este ejemplo, curl-devel causa que el proceso de instalación falle:

[20130208.081257] Setting up Install Process
[20130208.081257] Package curl-devel is obsoleted by libcurl-devel, trying to install libcurl-devel-7.21.7-5.el5.remi.2.x86_64 instead
[20130208.081257] Package libcurl-devel-7.21.7-5.el5.remi.2.x86_64 already installed and latest version
[20130208.081257] Package curl-devel is obsoleted by libcurl-devel, trying to install libcurl-devel-7.21.7-5.el5.remi.2.x86_64 instead
[20130208.081257] Package libcurl-devel-7.21.7-5.el5.remi.2.x86_64 already installed and latest version
[20130208.081257] Nothing to do
[20130208.081258] E Sysup: Needed system RPMs were not installed: curl-devel 
[20130208.081258] ***** FATAL: Cannot proceed. Needed system RPMs were not installed. 
[20130208.081258] The Administrator will be notified to review this output when this script completes
[20130208.081258] E Detected events which require user notification during updatenow. Will send iContact the log
=> Log closed Fri Feb 8 08:12:58 2013
[20130208.081258] E Running `/usr/local/cpanel/scripts/updatenow --upcp --log=/var/cpanel/updatelogs/update.1360329171.log` failed, exited with code 18 (signal = 0) 

Note que aparece el repositorio remi en el archivo de actualización. (Es posible que usted también vea epel.)
Primero, usted querrá revisar cuáles curl RPMs están instalados en su sistema con el comando rpm -qa|grep curl

compat-libcurl3-7.15.5-2.el5.remi 
curl-7.15.5-15.el5
curl-7.21.7-5.el5.remi.2
libcurl-devel-7.21.7-5.el5.remi.2 
libcurl-7.21.7-5.el5.remi.2 

Luego, confirme que está en uso un repositorio de terceros con el siguiente comando:

ls /etc/yum.repos.d/ 

Los resultados se parecerán al siguiente:

./ CentOS-Debuginfo.repo epel.repo remi.repo.save
../ CentOS-Media.repo epel-testing.repo 
CentOS-Base.repo CentOS-Vault.repo remi.repo

Si usted recibe resultados similares, esto significa que usted está usando el repositorio de terceros REMI para YUM. A menos que usted absolutamente necesite un repositorio de terceros, usted debe desactivar ese repositorio en /etc/yum.conf

yum-config-manager --disable repositoryname

Luego de que usted desactive el repositorio de terceros, ejecute nuevamente el proceso de actualización de cPanel.

Conflicto con un RPM defectuoso

En este ejemplo, MySQL causa que el proceso de instalación falle:

[20130128.230346] Testing RPM transaction 
[20130128.230348] error: Failed dependencies:
[20130128.230348] MySQL conflicts with mysql-5.0.77-4.el5_4.2.i386 
[20130128.230348] W Exit Code: 254
[20130128.230348] ***** FATAL: Test install failed: error: Failed dependencies: 
[20130128.230348] MySQL conflicts with mysql-5.0.77-4.el5_4.2.i386
[20130128.230348] The Administrator will be notified to review this output when this script completes
[20130128.230348] E Error testing if the RPMs will install: Died at /usr/local/cpanel/scripts/updatenow.static line 12517.
[20130128.230348] E Detected events which require user notification during updatenow. Will send iContact the log 

Note la versión de MySQL en el archivo de actualización. Usted puede obtener más detalles al ejecutar el siguiente comando: rpm -qa|grep mysql-5 

# rpm -qa|grep mysql-5 
mysql-5.0.77-4.el5_4.2

Luego, usted puede comparar ese RPM con los otros RPM de MySQL dentro del repositorio:

MySQL-server-5.5.28-2.cp.1132
MySQL-devel-5.5.28-2.cp.1132
MySQL-client-5.5.28-2.cp.1132
MySQL-test-5.5.28-2.cp.1132
MySQL-shared-5.5.28-2.cp.1132

La solución para este conflicto es eliminar el archivo RPM defectuoso y ejecutar nuevamente el proceso de actualización de cPanel. 

Una etiqueta inmutable

En este ejemplo, tar y unzip causan que el proceso de instalación falle:

[20130210.141900]   Running Transaction
[20130210.141903]   
[20130210.141903]   Installing     : gzip                                                     1/3 
[20130210.141903]   
[20130210.141903]   Installing     : unzip                                                    2/3Error unpacking rpm package unzip-5.52-3.el5.i386
[20130210.141903]    
[20130210.141903]   error: unpacking of archive failed on file /usr/bin/unzip: cpio: rename
[20130210.141903]   
[20130210.141903]   Installing     : tar                                                      3/3Error unpacking rpm package 2:tar-1.15.1-32.el5_8.i386
[20130210.141903]    
[20130210.141903]   error: unpacking of archive failed on file /bin/tar: cpio: rename
[20130210.141904]   
[20130210.141904]   Installed:
[20130210.141904]     gzip.i386 0:1.3.5-13.el5.centos                                               
[20130210.141904]   
[20130210.141904]   Failed:
[20130210.141904]     tar.i386 2:1.15.1-32.el5_8               unzip.i386 0:5.52-3.el5              
[20130210.141904]   
[20130210.141904]   Complete!
[20130210.141910] E Sysup: Needed system RPMs were not installed: tar, unzip, wget [20130210.141910] ***** FATAL: Cannot proceed. Needed system RPMs were not installed.
[20130210.141910]   The Administrator will be notified to review this output when this script completes
[20130210.141910] E Detected events which require user notification during updatenow. Will send iContact the log

Note las fallas relacionadas al desempaque del archivo.

El proceso de actualización no pudo desempacar el paquete nuevo en el lugar correcto.

Para arreglar este problema, revise los atributos de los binarios que se tienen que actualizar:

# lsattr /usr/bin/unzip
---i------- /usr/bin/unzip
---i------- /bin/tar 

Como puede observar, los binarios están configurados a inmutable (immutable). Usted puede eliminar las opciones inmutables con el siguiente comando:

chattr -i /usr/bin/unzip 
chattr -i /bin/tar

Conclusión

Si usted aún tiene problemas con el RPM durante el proceso de instalación, abra un ticket de soporte.

  • No labels